February 2014: Adobe Urges Users to Upgrade Flash Immediately | SecureIT | Kent State University

February 2014: Adobe Urges Users to Upgrade Flash Immediately

Adobe, the makers of Flash, announced a vulnerability in its software and is urging users to update right away. While Flash is primarily used for video and animated content, hackers try and exploit the software in order to steal information, money, or to take control of the system and use it to attack another system.

The developers of Flash and other browser add-ons check their code for exploits often, and once a possible exploit is found, the developers work to create a patch that can then be downloaded. Most add-ons will check for and install these patches automatically. Some of these add-ons are even built into the browser, meaning that when you update the browser, the add-ons update as well. It is recommended that you update your browser and add-ons frequently to protect yourself from hackers.

<-Read more back-issues of the Security Awareness eNewsletter